work
8236ec51ed
hopefully this will make it possible to have signed commits previously I tried using the protonmail one but I can't assign that to both the work and my personal account and I'm for sure not leaking my work email forgejo by default allows these fake emails so hopefully this works
21 lines
595 B
Nix
21 lines
595 B
Nix
{
|
|
inputs,
|
|
...
|
|
}: {
|
|
poz.programs.git = {
|
|
enable = true;
|
|
inherit (inputs.work-secrets.git) userName userEmail signingKey;
|
|
includes = [
|
|
{
|
|
condition = "hasconfig:remote.*.url:jacekpoz:*/**";
|
|
contents = {
|
|
user = {
|
|
email = "work@jacek.poz";
|
|
name = "work";
|
|
signingKey = "ssh-ed25519 AAAAC3NzaC1lZDI1NTE5AAAAIDmeOJA8S8P+Q8wgF57v8ygpVkj4qBp6iuclNGxeFv75";
|
|
};
|
|
};
|
|
}
|
|
];
|
|
};
|
|
}
|