78 lines
1.6 KiB
Nix
78 lines
1.6 KiB
Nix
{
|
|
config,
|
|
lib,
|
|
pkgs,
|
|
...
|
|
}: let
|
|
inherit (config.poz.other.system) username;
|
|
|
|
inherit (lib.attrsets) attrValues;
|
|
in {
|
|
users.users.${username}.packages = attrValues {
|
|
inherit (pkgs)
|
|
keepassxc
|
|
eza
|
|
ripgrep
|
|
signal-desktop-beta
|
|
element-desktop
|
|
obs-studio
|
|
heroic
|
|
ungoogled-chromium
|
|
tor-browser
|
|
mullvad-browser
|
|
thunderbird
|
|
gimp
|
|
easyeffects
|
|
libreoffice-fresh
|
|
qbittorrent
|
|
zellij
|
|
unzip
|
|
caprine-bin
|
|
trash-cli
|
|
networkmanagerapplet
|
|
xdg-utils
|
|
pamixer
|
|
brightnessctl
|
|
dig
|
|
imv
|
|
pcmanfm
|
|
xdg-ninja
|
|
gnupg
|
|
age
|
|
rage
|
|
fd
|
|
udisks
|
|
ffmpeg_6-full
|
|
yt-dlp
|
|
asciinema
|
|
asciinema-agg
|
|
dust
|
|
appimage-run
|
|
file
|
|
fastfetch
|
|
magic-wormhole
|
|
alsa-utils
|
|
imagemagick
|
|
psmisc
|
|
mesa-demos
|
|
jq
|
|
fq
|
|
progress
|
|
parallel
|
|
p7zip
|
|
xxd
|
|
mpc-cli
|
|
playerctl
|
|
xdg-user-dirs
|
|
lshw
|
|
tree
|
|
exiv2
|
|
libnotify
|
|
radicle-node
|
|
;
|
|
inherit (config.boot.kernelPackages)
|
|
cpupower
|
|
perf
|
|
;
|
|
};
|
|
}
|