niksos/hosts/common/optional/yubikey.nix
jacekpoz 23f5aaaf45
huge options refactor
due to being on a wifi and my sim card not being able to do its job
properly this might have some errors

`nix flake check` gave me none for the current host but tbh who knows

this commit moves everything from `options` to `hosts/common` and
modifies the `createHost` function to import part of the files under
that directory by default

there's also a `hosts/common/optional` which is still being imported in
`profile.nix` but now in a better way using `lib.path.append` in tandem
with `lib.lists.map`
2024-09-01 20:31:24 +02:00

27 lines
615 B
Nix

{
# config,
pkgs,
...
}: {
# }: let
# # inherit (config.poz.other.system) username;
# in {
security.pam = {
services = {
login.u2fAuth = true;
sudo.u2fAuth = true;
};
};
services.udev = {
packages = [ pkgs.yubikey-personalization ];
};
# age.secrets.yubikey-u2f-keys.file = ../../secrets/yubikey-u2f-keys.age;
# environment.etc."Yubico/u2f_keys".source = config.age.secrets.yubikey-u2f-keys.path;
# home-manager.users.${username} = {
# xdg.configFile."Yubico/u2f_keys".source = /etc/Yubico/u2f_keys;
# };
}