niksos/hosts/common/optional/adb.nix
jacekpoz 23f5aaaf45
huge options refactor
due to being on a wifi and my sim card not being able to do its job
properly this might have some errors

`nix flake check` gave me none for the current host but tbh who knows

this commit moves everything from `options` to `hosts/common` and
modifies the `createHost` function to import part of the files under
that directory by default

there's also a `hosts/common/optional` which is still being imported in
`profile.nix` but now in a better way using `lib.path.append` in tandem
with `lib.lists.map`
2024-09-01 20:31:24 +02:00

12 lines
194 B
Nix

{
config,
...
}: let
inherit (config.poz.other.system) username;
in {
programs.adb.enable = true;
users.users.${username} = {
extraGroups = [ "adbusers" ];
};
}