niksos/modules/cli/starship.nix
jacekpoz 59febb2149
move the config' arg to a custom module (big)
shoutout to raf for pointing out how retarded this was
this was needed very much
2024-02-29 00:29:56 +01:00

42 lines
1.4 KiB
Nix

{
config,
lib,
...
}: with lib; let
cfg = config.myOptions.programs.starship;
username = config.myOptions.other.system.username;
in {
options.myOptions.programs.starship.enable = mkEnableOption "enable starship";
config = mkIf cfg.enable {
home-manager.users.${username} = {
programs.starship = {
enable = true;
enableZshIntegration = config.myOptions.programs.zsh.enable;
settings = {
add_newline = false;
command_timeout = 1000;
line_break = {
disabled = true;
};
directory = {
truncation_length = 3;
truncate_to_repo = false;
truncation_symbol = "/";
};
c.symbol = " ";
directory.read_only = " 󰌾";
git_branch.symbol = " ";
haskell.symbol = " ";
hostname.ssh_symbol = " ";
java.symbol = " ";
kotlin.symbol = " ";
meson.symbol = "󰔷 ";
nix_shell.symbol = " ";
package.symbol = "󰏗 ";
rust.symbol = " ";
};
};
};
};
}