nix/modules/stuff/thunar.nix
2024-08-10 13:27:11 +02:00

32 lines
789 B
Nix

{ lib, pkgs, config, ...}: let
inherit (lib) mkIf mkEnableOption mkOption;
cfg = config.chuj.stuff.thunar;
user = config.chuj.system.user;
in {
options.chuj.stuff.thunar = {
enable = mkEnableOption "thunar";
};
config = mkIf cfg.enable {
programs = {
dconf.enable = true;
xfconf.enable = true;
thunar = {
enable = true;
plugins = with pkgs.xfce; [
thunar-volman
thunar-archive-plugin
thunar-media-tags-plugin
];
};
};
services.gvfs.enable = true;
services.tumbler.enable = true;
home-manager.users.${user}.home.packages = with pkgs; [
ffmpegthumbnailer
gsettings-desktop-schemas
xarchiver # not really thunar but can be here ig
samba
];
};
}