nix/modules/stuff/flameshot.nix

22 lines
523 B
Nix

{ lib, pkgs, config, ...}: let
inherit (lib) mkIf mkEnableOption mkOption;
cfg = config.chuj.stuff.flameshot;
user = config.chuj.system.user;
in {
options.chuj.stuff.flameshot = {
enable = mkEnableOption "flameshot";
};
config = mkIf cfg.enable {
home-manager.users.${user} = {
services.flameshot = {
enable = true;
settings = {
General = {
disabledTrayIcon = true;
showStartupLaunchMessage = false;
};
};
};
};
};
}