forked from poz/niksos
41 lines
1.6 KiB
Nix
41 lines
1.6 KiB
Nix
{ config, lib, pkgs, modulesPath, ... }:
|
|
|
|
{
|
|
imports =
|
|
[ (modulesPath + "/installer/scan/not-detected.nix")
|
|
];
|
|
|
|
boot.initrd.availableKernelModules = [ "xhci_pci" "ahci" "ohci_pci" "ehci_pci" "usb_storage" "usbhid" "sd_mod" ];
|
|
boot.initrd.kernelModules = [ ];
|
|
boot.kernelModules = [ "kvm-amd" "wl" ];
|
|
boot.extraModulePackages = [ config.boot.kernelPackages.broadcom_sta ];
|
|
|
|
fileSystems."/" =
|
|
{ device = "/dev/disk/by-uuid/ba9b94f8-7c2e-43e4-ae8b-d48836819321";
|
|
fsType = "btrfs";
|
|
};
|
|
|
|
fileSystems."/boot" =
|
|
{ device = "/dev/disk/by-uuid/43B9-A358";
|
|
fsType = "vfat";
|
|
};
|
|
|
|
swapDevices =
|
|
[ { device = "/dev/disk/by-uuid/8553092f-8960-4326-97d8-43af396eef82"; }
|
|
];
|
|
|
|
# Enables DHCP on each ethernet and wireless interface. In case of scripted networking
|
|
# (the default) this is the recommended approach. When using systemd-networkd it's
|
|
# still possible to use this option, but it's recommended to use it in conjunction
|
|
# with explicit per-interface declarations with `networking.interfaces.<interface>.useDHCP`.
|
|
networking.useDHCP = lib.mkDefault true;
|
|
# networking.interfaces.enp3s0f0.useDHCP = lib.mkDefault true;
|
|
# networking.interfaces.enp3s0f1.useDHCP = lib.mkDefault true;
|
|
# networking.interfaces.enp4s0f0.useDHCP = lib.mkDefault true;
|
|
# networking.interfaces.enp4s0f1.useDHCP = lib.mkDefault true;
|
|
# networking.interfaces.enp6s0.useDHCP = lib.mkDefault true;
|
|
|
|
nixpkgs.hostPlatform = lib.mkDefault "x86_64-linux";
|
|
powerManagement.cpuFreqGovernor = lib.mkDefault "ondemand";
|
|
hardware.cpu.amd.updateMicrocode = lib.mkDefault config.hardware.enableRedistributableFirmware;
|
|
}
|